Jump to content
AsamiImako

Ragnarok @ 2K or (possibly) even 4K IN FULL SCREEN!

Recommended Posts

If it does, please reply with more details about the issue you were having and your hardware/settings you used so other people with the same issue know about it :D

  • Like 1

Share this post


Link to post
Share on other sites
8 hours ago, Xetano said:

Didn't work for me AMD R9 390 (poor people's graphics card) :D

Hey there, can you please elaborate on what the issue was and what settings you tried? Maybe I can help!

Share this post


Link to post
Share on other sites
On 5/16/2017 at 3:58 AM, AsamiImako said:

Hey there, can you please elaborate on what the issue was and what settings you tried? Maybe I can help!

Thanks but I guess I'll be fine.  I don't play fullscreen anyway.  I just tried just for fun :)

Share this post


Link to post
Share on other sites

I must say that I spent a whole day on this and the client still borks around. I am not sure if I can recommend dgVoodoo at this point. Use at your own risk for sure.

  • Like 1

Share this post


Link to post
Share on other sites
17 hours ago, GM Boreas said:

I must say that I spent a whole day on this and the client still borks around. I am not sure if I can recommend dgVoodoo at this point. Use at your own risk for sure.

I only have two configurations I can test. The more people who share the configurations they tested and their experiences, the better understanding of the peculiarities of how Ragnarok Online and dgVooDoo interact we'll have, until perhaps we can find a best configuration for most people.

So far it seems it's best for most people to leave Fast Memory Access off, and to leave Full-Screen off in Ragnarok setup and toggle it using Alt+Enter instead. I haven't had to spoof GPUs on either of my configurations, the amount of texture memory hasn't seemed to cause any issues, nor has forcing anisotropic filtering.

By all means please share your findings. I've mostly just been playing with the settings I mentioned as they work fine, with no crashing or other issues to note.

Share this post


Link to post
Share on other sites

how to i remove it?? 

 

i already delete the .dll and the dgvoodoo exe files 

and want to run normally but client always closed when i click start.

 

Share this post


Link to post
Share on other sites
2 hours ago, vgenjr said:

how to i remove it?? 

 

i already delete the .dll and the dgvoodoo exe files 

and want to run normally but client always closed when i click start.

 

Make sure you revert to your previous settings in the Ragnarok Online setup. Most notably, make sure you aren't running in full-screen mode and make sure you aren't running at a resolution above 2048x1536.

Share this post


Link to post
Share on other sites

screenTalonRO041.thumb.jpg.74f01e4dfbc5142bbe4dce71e6929661.jpg

tried it.. but some sprites are missing when i'm moving.. i followed your guide above.. :)

edit: unchecked fast memory access fixed the missing sprites lol

Edited by khrei
added some text..

Share this post


Link to post
Share on other sites

One thing to remember: if you want to use the RO client's hotkey Alt-Enter to send messages to Guild Chat you have to tick the option "Disable Alt-Enter to toggle screen state" or else dgvoodoo will grab the hotkey and it wont reach the client.

Share this post


Link to post
Share on other sites

This fixed my fullscreen problem, i used to cannot go in fullscreen because it will cause it to be distorted.

well there is a problem with this tool, i get some fps drop with it, especially on crowded places. Any idea which settings to just allow my game to go fullscreen but doesnt alter the graphic so i dont get fps drop? bad pc here.

I already set the anisotropic filtering as app driven, yet its the same fps drops with 16x filtering, weird.

  • Fsh 1

Share this post


Link to post
Share on other sites
10 hours ago, Dingo-kun @ Dong said:

[...]

well there is a problem with this tool, i get some fps drop with it, especially on crowded places. Any idea which settings to just allow my game to go fullscreen but doesnt alter the graphic so i dont get fps drop? bad pc here.

I already set the anisotropic filtering as app driven, yet its the same fps drops with 16x filtering, weird.

I found that activating "Force vSync" has the biggest impact on FPS for me. So I just decided to live with tearing effects but somewhat stable FPS in Prontera. Outside Prontera or Pron_Mall I never had any issues with low FPS.

About Filtering the RO Client itself has no option to enable Anisotropic Filtering it only supports Trilinear. So if you want Anisotropic Filtering you have to set Force Anisotropic. I didn't see any performance impact from forcing filters but Anisotropic looks a little nicer especially on those roof tops in Prontera.

  • Fsh 1

Share this post


Link to post
Share on other sites
12 hours ago, DoucheEnrique said:

I found that activating "Force vSync" has the biggest impact on FPS for me. So I just decided to live with tearing effects but somewhat stable FPS in Prontera. Outside Prontera or Pron_Mall I never had any issues with low FPS.

About Filtering the RO Client itself has no option to enable Anisotropic Filtering it only supports Trilinear. So if you want Anisotropic Filtering you have to set Force Anisotropic. I didn't see any performance impact from forcing filters but Anisotropic looks a little nicer especially on those roof tops in Prontera.

okei thanks bruh, ima have a try later i get back from brunch :>

EDIT : you were half right about force v-sync causing some fps drop, but even when i keep it off, i still have fps drop at prontera... but not as bad as v-sync on, for the meantime i think i'll stick to window mode, until i decide to buy a newer computer. =\

Edited by Dingo-kun @ Dong

Share this post


Link to post
Share on other sites

this fixed my issue completely but just to nit pick when i open another copy of talonro it makes the first one go back to being all distorted until i close that window out and reopen talonro completely so only the newest opened window is all fixed the rest are all distorted, is there a way to make it so this doesn't happen?

Edited by Sgf

Share this post


Link to post
Share on other sites
3 hours ago, Sgf said:

this fixed my issue completely but just to nit pick when i open another copy of talonro it makes the first one go back to being all distorted until i close that window out and reopen talonro completely so only the newest opened window is all fixed the rest are all distorted, is there a way to make it so this doesn't happen?

as mentioned earlier "fast memory access" tends to do that. turn that off to reduce glitching.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, DoucheEnrique said:

as mentioned earlier "fast memory access" tends to do that. turn that off to reduce glitching.

this did not fix the issue, it still causes the other window to become distorted again, still can only have 1 Fixed window at a time, all my settings are exactly as shown in the guide aswell

Share this post


Link to post
Share on other sites
20 hours ago, Sgf said:

this did not fix the issue, it still causes the other window to become distorted again, still can only have 1 Fixed window at a time, all my settings are exactly as shown in the guide aswell

What's your generic system setup? CPU, GPU, RAM, Windows version etc.pp.

Share this post


Link to post
Share on other sites
2 minutes ago, DoucheEnrique said:

What's your generic system setup? CPU, GPU, RAM, Windows version etc.pp.

2600k gtx980 16gb windows 7, upon further investigation it appears just simply alt tab onto my desktop makes the window go all distorted again, not even a matter of opening another copy of Talonro

Share this post


Link to post
Share on other sites

That's pretty close to my setup. This is the current setting I'm playing with:

dgvoodoo_a.png.e0f7d51b684f357a4aa11ba0cc86fba4.pngdgvoodoo_b.png.12855874b3b4c260cf9d3de8de86ab7b.png

I tried changing the Ragnarok Setup to Fullscreen but that didn't give me any problems with multiple clients / switching application focus. The only time I had problems like these were with "Fast video memory access" activated.

Did you notice the changes in dgvoodoocpl.exe actually changing anything ingame? Maybe you are running the game as Administrator (through the patcher) but do all the changes in dgvoodoo.cpl as regular user. That way the settings wouldn't affect the actual game.

/hmm  . . .

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Fenk
      Here is a quick solution on how to fix Ragnarok Online's pixelated or blurry graphics,
      particularly for NVIDIA GTX TItan 750 Ti and above users.
      ____________________________________________________________________________________________________
      Does your Ragnarok graphics look like the screenshot below?
      ____________________________________________________________________________________________________

      ____________________________________________________________________________________________________
      Even emoticons are blurred.
      ____________________________________________________________________________________________________

      ____________________________________________________________________________________________________
      This may be due to the latest video cards to date.
      ____________________________________________________________________________________________________
      Video Cards Like: NVDIA GTX 750, 750 Ti, 770, 780, 780 Ti and above graphics card.
      Possible Reason: 
      1. Ragnarok was built for previous generation video cards (not high-end ones). It is in fact similar to teaching an old man how to use the latest gadgets such as smartphones and tablets. They can use it but it's not as clear as how young people see it. 
      ____________________________________________________________________________________________________
      SOLUTION
      ____________________________________________________________________________________________________
      There is a solution but it's not permanent and it is in fact easy that it's not really troublesome to do.
      BELOW ARE THE STEPS:
      Step 1. Log in to the game. Similar to how the previous screenshot is shown.

      THIS IS THE TRICKY PART. DO EXACTLY AS HOW IT IS TOLD.
      Step 2. Once you are logged in, press CTR+ALT+DELETE until the TASK MANAGER screen is shown. (see image below)

      Step 3. Don't do anything on the task manager.
      Step 4: Press ESC or Cancel once the task manager is shown. 
      Step 5: Now the graphics is fixed.

      ____________________________________________________________________________________________________
      I hope it helped solve your graphics problem.
       Welcome and enjoy playing TalonRO! 
      ____________________________________________________________________________________________________
      Necro
      ____________________________________________________________________________________________________
×