Jump to content
  • 7
Karpastein

How to fix the white screen problem!

Question

First of all, sorry for any eventual mistake. English is not my primary language.

So, after 2 days (yes, 2 f.days) i found out that some 32-bits programs are incompatible with 64-bits based system AND with more than 2 or 4 CPU cores. Yeah... no kidding...
I was getting the white screen error everytime I tried to play the game. Start Game on patcher than BAM, White Screen of Doom and stopped working.

As said before, my system is 64 bits and the exe is 32 bit and I have a 6 core (AMD FX 6300).  While searching I found out this link:
http://www.tomshardware.com/forum/53426-63-solved-32bit-program-longer-working-64bit-win7

And then this thread:

So the thing is: 
- Create a talonexe.exe shortcut
- Right click 
- Properties
- Target line goes for  C:\Windows\System32\cmd.exe /C start "" /affinity 2 "the path you have"  -1sak1  
- Open the game through the shortcut.

You will still need to open the patcher to... patch new patches... and the setup works normaly.

And with that my game is working perfectly now :D 
Hope it helps if somebody is having the same problem and compatibility mode or others alternatives aren't working. This might be your case too.

And a big thanks to Ramesses for (somehow) helping in this too!

  • Like 4
  • Love 3
  • No1 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
On 10/4/2017 at 12:05 PM, Karpastein said:

First of all, sorry for any eventual mistake. English is not my primary language.

So, after 2 days (yes, 2 f.days) i found out that some 32-bits programs are incompatible with 64-bits based system AND with more than 2 or 4 CPU cores. Yeah... no kidding...
I was getting the white screen error everytime I tried to play the game. Start Game on patcher than BAM, White Screen of Doom and stopped working.

As said before, my system is 64 bits and the exe is 32 bit and I have a 6 core (AMD FX 6300).  While searching I found out this link:
http://www.tomshardware.com/forum/53426-63-solved-32bit-program-longer-working-64bit-win7

And then this thread:

So the thing is: 
- Create a talonexe.exe shortcut
- Right click 
- Properties
- Target line goes for  C:\Windows\System32\cmd.exe /C start "" /affinity 2 "the path you have"  -1sak1  
- Open the game through the shortcut.

You will still need to open the patcher to... patch new patches... and the setup works normaly.

And with that my game is working perfectly now :D 
Hope it helps if somebody is having the same problem and compatibility mode or others alternatives aren't working. This might be your case too.

And a big thanks to Ramesses for (somehow) helping in this too!

I'm using a PC with Ryzen CPU & Radeon graphic card and faces same problem (no nahimic / built-in audio software whatsoever).

This solution really worked for me. Thank you!

 

But recently I updated my graphic card driver and just found out that I no longer need the modified shortcut for TalonRO to work!

My recommendation, update your devices' driver, it's worth a shot.

Share this post


Link to post
Share on other sites
  • 2

Hey, 

I got the same problem back in 2017 ....... 4 days ago. XD 
and i fixed it without any complicated (cmd) actions.

Win 10, AMD Radeon R7. 

So, what I did is .... *drum roll* I checked my computer on updates and saw, my AMD wanted a new update. So, I updated and everything went perfect (y) 

You're welcome. 

  • Love 1

Share this post


Link to post
Share on other sites
  • 1
9 hours ago, kimjungbill said:

i dont understand what you mean by the path you have

"path" shows the spot, where the files are.. your path should include the .exe file

c:\games\tro  <-- this is a path

c:\windows\system32\  <-- also path..

if you check the link to the older topic, it shows: "D:\Games\RO\TalonRO\talonexe.exe -1sak1 /affinity 1"

the new one updates it to "C:\Windows\System32\cmd.exe /C start "" /affinity 2 "the path you have"  -1sak1 "

so instead of "the path you have" you insert the path, that will be something like c:\games\talonro\talonexe.exe.. you can see this on top of your file manager..

thats how I understand it..

Share this post


Link to post
Share on other sites
  • 1
Posted (edited)

I'm having the same problem, and by adding this on the path fixed the issue C:\Windows\System32\cmd.exe /C start "" /affinity 2 "

-create a shortcut

-rightclick the icon

-select properties

-add this on the beginning of the path (target) 

C:\Windows\System32\cmd.exe /C start "" /affinity 2 "

 

mine look like this

 C:\Windows\System32\cmd.exe /C start "" /affinity 2 "E:\TalonRO\TalonPatch.exe

 

Edited by darkyow
  • Thanks 1

Share this post


Link to post
Share on other sites
  • 1
45 minutes ago, Kedarui said:

i'm really sorry but this whole thread makes literally no sense to me... i'm not a smart person by any means so every solution is just horribly confusing. 

my path is "(C:) -> Games -> TalonRO". what do i do from there? if possible, please write out the rest of what i should add to the path so i can just copy and paste it or else i'll never be able to play this game ;_;

omg, i actually did it on my own

it worked when i put this inC:\Windows\System32\cmd.exe /C start /affinity 2 C:\Games\TalonRO\talonexe.exe -1sak1

this is a semi-direct copy+paste from the "single CPU command" thread. the original was this: C:\Windows\System32\cmd.exe /C start /affinity 2 E:\Games\RO\TalonRO\talonexe.exe -1sak1

i hope this helps anyone else!

  • No1 1

Share this post


Link to post
Share on other sites
  • 0
On 10/4/2017 at 12:05 PM, Karpastein said:

First of all, sorry for any eventual mistake. English is not my primary language.

So, after 2 days (yes, 2 f.days) i found out that some 32-bits programs are incompatible with 64-bits based system AND with more than 2 or 4 CPU cores. Yeah... no kidding...
I was getting the white screen error everytime I tried to play the game. Start Game on patcher than BAM, White Screen of Doom and stopped working.

As said before, my system is 64 bits and the exe is 32 bit and I have a 6 core (AMD FX 6300).  While searching I found out this link:
http://www.tomshardware.com/forum/53426-63-solved-32bit-program-longer-working-64bit-win7

And then this thread:

So the thing is: 
- Create a talonexe.exe shortcut
- Right click 
- Properties
- Target line goes for  C:\Windows\System32\cmd.exe /C start "" /affinity 2 "the path you have"  -1sak1  
- Open the game through the shortcut.

You will still need to open the patcher to... patch new patches... and the setup works normaly.

And with that my game is working perfectly now :D 
Hope it helps if somebody is having the same problem and compatibility mode or others alternatives aren't working. This might be your case too.

And a big thanks to Ramesses for (somehow) helping in this too!

Hello,

I am having the same problem.
My Talon RO is intalled under Drive C>GAMES>TALON RO

could u advise me what should i do? i am bad with computer stuff.
Thank you so much for helping.

Share this post


Link to post
Share on other sites
  • 0

Sorry for bumping an old thread. Same problem with me i tried with this path but still doesnt work

C:\Windows\System32\cmd.exe /C start "" /affinity 2 "C:\Games\TalonRO\talonexe.exe"  -1sak1

Im not sure if im missing something

Share this post


Link to post
Share on other sites
  • 0

I have tried and the shortcut is, for me, 

C:\Windows\System32\cmd.exe /C start "" /affinity 2 "E:\TalonRO\TalonPatch.exe"  -1sak1

 

and also tried

 

C:\Windows\System32\cmd.exe /C start "" /affinity 2 "E:\TalonRO\Talonexe.exe"  -1sak1

But it doesn't solve my problem. I start the game, I see a black screen with a white square for a couple of seconds, then it closes back. My video card is GTX 1080 ti.

Share this post


Link to post
Share on other sites
  • 0
On ‎10‎/‎11‎/‎2017 at 2:54 PM, Ashley Wong said:

Hello GM,

I dont understand what i am supposed to do with this part : - Target line goes for  C:\Windows\System32\cmd.exe /C start "" /affinity 2 "the path you have"  -1sak1  

what is this mean? sorry i am bad with computers. it used to work fine for me. Tried reinstalling too. but still not working yet.

I think, What the guide meant to say was.

- Target line goes for C:\Windows\System32\cmd.exe /C start "" /affinity 2 " *Where you kept your talonRO file*\talonexe " -1sak1

And then open the game with that shortcut, It worked Really well~

Edited by IceCubeSnowFlakes

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

do this

1.- Send to desktop ''talonexe.exe''

 

1.png

 

2: Properties of our new shortcut

 

2.png

 

 

3: Change the ''target'' line

copy all-> C:\Windows\System32\cmd.exe /C start "" /affinity 2  yourcarpetlocation\talonexe  -1sak1

3.png

Edited by juampi284
  • Love 1

Share this post


Link to post
Share on other sites
  • 0

My problem was solved just by closing my Nahimic (MSI sound enhancer application) application, it runs as a background program (You can check by clicking the up arrow symbol beside your wifi symbol in the taskbar, or go to task manager then find the application).

Close/Exit the Nahimic application that is running in the background, then launch the patcher again.

No need to uninstall those sound enhancer application.

My laptop is MSI GE62-6QE Apache Pro. Hope it helps!

Share this post


Link to post
Share on other sites
  • 0
On 1/8/2018 at 6:02 PM, juampi284 said:

do this

1.- Send to desktop ''talonexe.exe''

 

1.png

 

2: Properties of our new shortcut

 

2.png

 

 

3: Change the ''target'' line

copy all-> C:\Windows\System32\cmd.exe /C start "" /affinity 2  yourcarpetlocation\talonexe  -1sak1

3.png

I followed these steps one by one and it worked for me in the end.  I appreciate these instructions to solve the "White Screen" issue.  I would like to thank you for sharing this. 

Edited by Cray
  • Love 1

Share this post


Link to post
Share on other sites
  • 0

is there another fix?...
your solution works...but damn...i have to download updates from 2016...everytime...

 

Share this post


Link to post
Share on other sites
  • 0

Hey guys,

 

Btw didn't work for me completly still had the white screen.

I had to click on voodoo3 graphics card and then it worked *_*

 

Cy@

Share this post


Link to post
Share on other sites
  • 0

Hey again guys,

 

Something else I just found out it might help some guys.

The game wouldn't start today again...

I was like its because of the yesterday updates, I was kinda sad to be honest :D

And then a genius move came to me :

I just clicked on exit on my ASUS ROG PHOEBUS

image.png.9b28b895f681b76b51504d15bfa9c9f2.png

 

And then tada ! It also works now without the voodoo3 in the rag's settings.

So I'd say that the game is really annoying with simple stuff and it can be anything lol.

Maybe the audio softwares are linked to this common CPU core problem on Ragnarok Online.

 

I hope it helps,

Cy@

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

I encountered this white screen. Fixed by below step.

  • Install "TalonRO"
  • Install "Microsoft C++ Redistributable Packages 2008 and 2012"
  • Close "Alienware Sound Center"

System Specs: Alienware 15 R3 | Windows 10 - 64 bit | Nvidia GTX 1070

Edited by antibacterial

Share this post


Link to post
Share on other sites
  • 0
On 10/11/2017 at 6:54 PM, Ashley Wong said:

Hello GM,

I dont understand what i am supposed to do with this part : - Target line goes for  C:\Windows\System32\cmd.exe /C start "" /affinity 2 "the path you have"  -1sak1  

what is this mean? sorry i am bad with computers. it used to work fine for me. Tried reinstalling too. but still not working yet.

check 3rd party sound application software and just exit that application, this is what i did on my alienware, closed "alienware sound center"and can play smoothly. switching between dota 2 and ragnarok now. just need to enable alienware sound center again to play dota 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×